Identity Web SDK
2.4.2
Search…
⌃K

SDK Requirements

Remember to familiarize yourself with our image input guidelines!

Minimum development environment requirements

  • Any IDE
  • Hostable environment, e.g. IIS

Minimum device requirements:

  • Webcam or camera component capable of at least 1920×1080 capture.
Feature phones are NOT supported. Smartphone required for mobile.

Operating system requirements:

  • For Desktop
    • Any operating system that supports video capture (hardware and driver support for your device) and one or more of our supported browsers.
  • For mobile
    • iPhones: iOS 14.1 or later
    • Android devices: Android 8 (Android Oreo. API level 26)
    • Other: Operating system that supports video capture, can lend video access to the active browser, and supports browsers that can utilize HTML5 features.
Please note that the web SDK will NOT work on third party browsers if the user is running an iOS version older than 14.3. In this case Safari will have to be used.

Supported browser versions:

  • Google Chrome: 91.0.4472
  • Microsoft Edge: 91.0.864.37
  • Mozilla Firefox: 89.0.1
  • Opera: 76
  • Apple Safari: 14.1
The Sybrin Identity Web SDK is not expected to work properly on browser versions older than those specified above.

Estimated size

When the Sybrin Identity Web SDK is implemented it will add to the page's total size.
Total expected size increase is approximately 8MB uncompressed and 1.1MB with GZIP enabled.